Main Content

本页的翻译已过时。点击此处可查看最新英文版本。

在键入时检查语法

语法高亮显示

为帮助您标识 MATLAB® 元素,某些条目在命令行窗口、编辑器和实时编辑器中以不同颜色显示。这种彩色显示称为语法高亮。默认情况下:

  • 关键字为蓝色。

  • 字符向量为紫色。

  • 未结束的字符向量为褐红色。

  • 注释为绿色。

% check to see if A is greater than B
if A > B
'greater'
elseif A < B
'less'
end

除错误外,命令行窗口中的任何输出都 以语法高亮显示方式出现。

MATLAB 软件将所选内容以 RTF 格式复制到剪贴板,许多 Microsoft® Windows®Macintosh 应用程序支持此功能。当您将选定内容从编辑器和实时编辑器粘贴或拖动到另一应用程序(例如 Microsoft Word)时,所粘贴的文本将保持编辑器和实时编辑器中的语法高亮颜色和字体特征。

要更改语法高亮预设项,请在主页选项卡的环境部分中,选择 预设。然后,选择 MATLAB > 编辑器/调试器 > 语言,并从语言下拉列表中选择一种语言。要更改 MATLAB Online™ 中的语法高亮预设项,请选择编辑器/调试器 > MATLAB 语言编辑器/调试器 > 其他语言

分隔符匹配

MATLAB 指示匹配和不匹配的分隔符(例如圆括号、方括号和花括号)来帮助您避免语法错误。MATLAB 还指示成对出现的语言关键字,例如 forifwhileelseend 语句。

在编辑器和实时编辑器中,MATLAB 通过短暂地为配对的分隔符加下划线来指示匹配的分隔符。在命令行窗口中,匹配的分隔符通过突出显示而不是下划线来指示。在 MATLAB Online 中,命令行窗口行为与编辑器和实时编辑器行为匹配。

MATLAB 通过短暂地对不匹配的分隔符加删除线,指示编辑器、实时编辑器和命令行窗口中的不匹配分隔符。

如果存在匹配的分隔符,但屏幕上却看不到该分隔符,则会打开一个窗口并显示包含匹配分隔符的行。在窗口中点击可转到该行。

您可以更改 MATLAB 是否以及何时针对匹配和不匹配的分隔符向您发出警报。在主页选项卡上的环境部分中,点击 预设。选择 MATLAB > 键盘,并在分隔符匹配部分,从可用选项中进行选择。

代码建议和自动填充项

当您编写代码时,MATLAB 会建议并填充函数、模型、MATLAB 对象、文件、文件夹、变量、结构体、图形属性、参数和选项的名称。使用这些自动建议和填充功能可以更快地写入命令并避免录入错误。

编辑器和实时编辑器会在您键入时显示可能的匹配项。要在脚本中插入某个匹配项,请使用箭头键选择所需的名称,然后按 Tab 键。按 Esc 键将清空自动填充项列表而不进行任何选择。

仅在您按下 Tab 键后,命令行窗口才会显示可能的匹配项。要在命令行窗口中自动填充名称,请键入要自动填充的名称的前几个字符,然后按 Tab 键。使用箭头键选择所需的名称,然后再次按 Tab 键。在 MATLAB Online 中,命令行窗口行为与编辑器和实时编辑器行为匹配,在您键入时显示可能的匹配项。

填充图形属性的名称和值时,自动建议和填充功能特别有用。例如,plot(x,y,'LineStyle','-')

您还可以使用建议功能来填充某些函数的参数名称和选项。例如,format('shortEng')

在输入包含函数的语句时,MATLAB 可能会建议该函数的多种语法。要查看更多语法,请点击语法右侧的箭头。也可以按 Ctrl + 向下箭头键盘快捷方式显示和隐藏更多语法。在 macOS 系统上,使用 Command 键而不是 Ctrl 键。

类似地,如果 MATLAB 建议了多个参数,点击参数描述右侧的箭头可以查看更多参数。也可以使用 Ctrl + Alt + 向右箭头Ctrl + Alt + 向左箭头键盘快捷方式。

MATLAB 根据其当前状态显示建议,包括:

  • 在当前工作区中定义的变量。

  • 搜索路径或当前文件夹中的文件和文件夹。

  • 在活动文档中定义并在光标当前位置可用的变量、函数、类属性和类方法。

MATLAB 不会填充仅在活动文件中定义的结构体数组的字段名称。

提示

要在启用建议和自动填充时在语句中插入一个制表符,请首先添加一个空格。然后,按 Tab 键。否则,MATLAB 会尝试自动填充名称。在实时编辑器中,如果启用建议和自动填充,但没有可用的自动填充,则 MATLAB 会插入一个制表符。

禁用自动建议和自动填充

在编辑器和实时编辑器中,要使 MATLAB 仅在您按下 Tab 键后建议和自动填充名称,请在视图选项卡的显示部分中,点击 自动填充按钮以将其关闭。或者,您可以转到主页选项卡,然后在环境部分点击 预设。然后,选择编辑器/调试器 > 自动填充,并在建议和自动填充部分中选择按 Tab 键时显示

在命令行窗口中,要禁用建议和自动填充,请在预设项窗口中选择 MATLAB > 命令行窗口 > 自动填充,并清除启用 Tab 键自动填充选项。

MATLAB Online 的命令行窗口中,要使 MATLAB 仅当您按 Tab 键后才建议并自动填充名称,请在主页选项卡的环境部分中,点击 预设。然后,选择 MATLAB > 命令行窗口 > 自动填充,并在建议和自动填充部分中选择按 Tab 键时显示

函数语法提示

当您在命令行窗口、实时编辑器或编辑器中输入函数时,将会在窗口中打开语法提示,显示该函数所能接受的输入参数。

对于 MATLAB 安装的函数和您创建的函数,会显示函数语法提示。MATLAB 函数的语法提示来自文档。您创建的函数的语法提示来自 MATLAB 程序文件中的函数定义语句(第一个可执行代码行)。该文件必须在搜索路径上或在当前文件夹中。有关向您创建的函数添加帮助的详细信息,请参阅为程序添加帮助

要使用函数语法提示,请键入带有左圆括号的函数名称。一个窗口随即打开,显示该函数的基本语法。在编辑器和实时编辑器(以及 MATLAB Online 中的命令行窗口)中,您可以使用语法右侧的下拉箭头 来显示所有可用的语法。

蓝色部分表示待输入的参数。输入您自己的参数名称,而非窗口中显示的参数名称。显示的语法选项会随您刚刚输入的参数而变化。

在编辑器和实时编辑器(以及 MATLAB Online 的命令行窗口)中,MATLAB 会显示每个参数的说明。可选参数由参数说明旁边的(可选)关键字指示。

某些函数名称已重载。也就是说,存在支持不同输入类型的同名函数。重载的函数需要您将对象作为第一个输入来传递。在指定对象名称时,语法提示会更新以反映函数的正确版本,如下图所示。实时编辑器可能不会显示所有重载。

函数语法提示只是建议。有关某函数的详细信息,请参阅文档中该函数的参考页。要打开该函数的文档,请点击该函数语法提示左侧的 按钮。

要在命令行窗口中禁用函数语法提示,请在主页选项卡的环境部分中,点击 预设。然后,选择 MATLAB > 命令行窗口 > 自动填充,并在建议和自动填充部分清除启用函数提示MATLAB Online 中的编辑器、实时编辑器或命令行窗口不支持禁用函数语法提示。