Main Content

本页的翻译已过时。点击此处可查看最新英文版本。

Simulink 建模的键盘快捷方式和鼠标操作

键盘快捷方式和鼠标操作可以帮助您在 Simulink® 中高效地进行系统建模。要从模型打开此页面,请按下 Shift+? 或点击导航栏上的 Keyboard Shortcuts 按钮

注意

以下键盘快捷方式基于 Windows®。在 Mac 上,按 command (⌘) 代替 Ctrl

执行文件和剪贴板操作

任务快捷方式
打开模型Ctrl+O
创建模型Ctrl+N
打印模型Ctrl+P
将所有修改的模型保存在当前模型层次结构中Ctrl+S
保存当前引用模型Ctrl+Shift+S
关闭模型Ctrl+W
剪切Ctrl+X
粘贴Ctrl+V
复制Ctrl+CCtrl+V
撤消Ctrl+Z
重做Ctrl+Y
查找搜索字符串Ctrl+F

缩放、滚动和更改当前窗口

任务操作
使图适合屏幕 空格键
放大Ctrl+加号 (+)
缩小Ctrl+减号 (-)
缩放至 100%Ctrl+0Alt+1
使用滚轮缩放

滚轮

Ctrl + 滚轮(当 Scroll wheel controls zooming 处于清除状态时)

放大模块图元素将选项板上的 Zoom 按钮 拖放到元素上。
滚动

空格键 + 拖动。

滚轮 + 拖动。

更改选项卡Ctrl+Shift+Tab
转至上一窗口Alt+Tab

导航模型层次结构

任务快捷方式
打开

双击。

Enter

转至当前子系统或引用模型的父级Esc
在模块封装下查找Ctrl+U
对于链接模块,转至父模块的库Ctrl+L
打开模型资源管理器Ctrl+H

修改模块图内容

任务操作
使用快速插入菜单在当前位置插入模块

双击 Simulink Editor 画布并开始键入模块名称;然后从菜单中选择模块。

Ctrl+句点 (.) 两次并开始键入模块名称,然后按向下箭头从列表中选择模块,并按 Enter 插入模块。

在 AZERTY 键盘上,按 Ctrl+Shift+句点 (.) 而不是 Ctrl+句点 (.)

获取基于上下文提供的模块建议提示双击以现有模块为起点绘制的信号线的末端,然后从列表中选择一项建议或直接键入以从库中选择一项建议。
打开库浏览器Ctrl+Shift+L
使用快速插入菜单在当前位置插入注释

双击 Simulink Editor 画布并键入注释内容,然后选择注释选项。

Ctrl+句点 (.) 两次并键入注释内容,然后使用向下箭头键选择注释选项,并按 Enter 键插入注释。

在 AZERTY 键盘上,按 Ctrl+Shift+句点 (.) 而不是 Ctrl+句点 (.)

复制所选模块图元素

用鼠标右键拖动元素。

Ctrl + 拖动。

在 Simulink Editor 窗口之间复制所选模块图元素在窗口之间拖动元素。
删除所选模块图元素DeleteBackspace

选择模块图元素

所选元素具有蓝色实线轮廓。除了轮廓之外,最近选择的元素还有蓝色角框。当您使用键盘进行选择时,为了表示光标,元素周围有蓝色虚线框。

The Product block is selected, the Gain block was selected most recently, and the cursor is on the Sum block.

任务操作
点击或移动元素后,访问用于选择元素的键盘快捷方式

M 键用于在修改所选内容和移动所选元素之间切换

将所选内容改为在某个方向上向最接近的相似元素

向左、向右、向上或向下箭头

将光标移至某个方向上最接近的元素,而不考虑相似性

Ctrl+Shift + 向左、向右、向上或向下箭头

将所选内容改为画布左上角的元素

Ctrl+Home

Mac 上,按 home

将所选内容改为画布右下角的元素

Ctrl+End

Mac 上,按 end

将所选内容改为相对于光标最左侧的元素

Home

Mac 上,按 control+left

将所选内容改为相对于光标最右侧的元素

End

Mac 上,按 control+right

选择其他相邻元素

从空位置拖动。

Shift + 向左、向右、向上或向下箭头

选择不相邻的其他元素

Shift + 点击。

Ctrl + 向左、向右、向上或向下箭头来更改当前元素。Ctrl + 空格键将当前元素添加到所选内容中。

Mac 上,要将当前元素添加到所选内容中,按 command+shift + 空格键或 shift + 空格键。

选择所有模块、信号线和注释Ctrl+A
选择端口指向已连接端口的端口区域,以查看底层端口并与之交互,而不是信号线。

修改模块图元素

任务快捷方式
为所选模块设置主要参数Alt+Enter
打开或隐藏属性检查器Ctrl+Shift+I
连接模块

点击端口。点击您要连接的兼容端口附近出现的蓝色向前符号 port hint symbol

选择第一个模块,然后按住 Ctrl 键并点击第二个模块。

从端口拖动到端口。

点击一个端口,在连接到下一个端口时按住 Shift。按住 Shift 连续进行多个连接。

分支信号线

点击一个端口,将光标移至要分支的信号线的附近,然后看到预览后点击。

选择一个信号线,将光标移向要连接的元素,然后点击出现在端口旁边的蓝色向前符号 port hint symbol

Ctrl + 拖动信号线。

鼠标右键 + 拖动。

将端口添加到接受多个输入的模块

从兼容的模块或信号线向端口拖动。

从要添加端口的模块的边拖动。

点击端口的边,然后拖动。

点击端口的边,将光标移至菜单上的信号(类型包括信号、总线或连接线)上,然后拖动。

注释直通所选模块Ctrl+Shift+Y
注释掉或取消注释所选模块Ctrl+Shift+X
对所选模块断开连接

Shift + 拖动模块。

用键盘选择模块后,按 M 键,然后按 Shift + 向左、向右、向上或向下箭头。

命名模块图元素

任务操作
重命名所选模块图元素

点击或双击标签。

选择元素,然后按 F2

Mac 上,按 command+return 而不是 F2

命名信号线双击信号并键入其名称。
在命名的信号线的分支上显示名称双击分支。
为一个信号的每个分支命名 右键点击该信号,选择 Properties,然后使用对话框进行操作。
删除信号标签和名称删除标签中的字符,或者在 Signal Properties 对话框中删除名称。
只删除信号标签 右键点击标签,然后选择 Delete Label
复制信号标签Ctrl + 拖动信号标签。
编辑子系统模块上的端口标签

指向端口标签,然后点击交互式提示。

选择端口。点击端口标签上的交互式提示或按 F2

修改模块图外观

任务操作
移动任一模块图元素,包括信号标签拖动元素。
移动所选元素

拖动所选元素之一。

拖动以形成一个选择框。

用键盘选择元素后,按 M 键,然后按向左、向右、向上或向下箭头。

调整模块大小,同时保持高宽比Shift + 拖动控制柄。
从中心调整模块大小Ctrl + 拖动控制柄。
在模块周围绘制信号线绘制时按住 Shift 键并拖动。
顺时针旋转模块Ctrl+R
逆时针旋转模块Ctrl+Shift+R
翻转模块Ctrl+I
根据选择创建子系统Ctrl+G
从空选择区创建子系统或区域

要创建突出显示的选项(您可以使用箭头键或鼠标对其进行更改),请执行以下操作:

  • 在选择框内点击。

  • Enter

按下与选项相关联的数字键。

更改信号标签字体选择信号线(不是标签),然后在 Format 选项卡上,点击 Font Properties 按钮箭头,然后点击 Fonts for Model
封装模块Ctrl+M
刷新 Model 模块Ctrl+K

执行操作

任务快捷方式
使用快速操作搜索菜单执行一般操作

双击 Simulink Editor 画布,选择 Actions 选项卡,并开始键入操作名称或说明,然后从列表中选择操作。

Ctrl+句点 (.) 并开始键入操作名称或说明,然后按向下箭头选择操作,并按 Enter 执行操作。

在 AZERTY 键盘上,按 Ctrl+Shift+句点 (.) 而不是 Ctrl+句点 (.)

执行上下文相关操作

在打开快速操作搜索菜单之前,选择一个模块图元素。

对模型进行更新、仿真和生成代码

任务快捷方式
打开 Configuration Parameters 对话框Ctrl+E
更新模型Ctrl+D
开始仿真Ctrl+T
停止仿真Ctrl+Shift+T
构建模型(用于代码生成)Ctrl+B

调试模型

任务快捷方式
步骤F10
步入F11
步出Shift+F11
运行F5
设置或清除断点F12

另请参阅

|

相关主题