本页对应的英文页面已更新,但尚未翻译。 若要查看最新内容,请点击此处访问英文页面。

安装设备驱动程序的硬件支持包

要与 CAN 设备通信,您必须在系统上安装所需的驱动程序。

以下供应商的支持包中提供这些驱动程序:

  • National Instruments® (NI-XNET CAN)

  • Kvaser

  • Vector

  • PEAK-System

注意

对于已部署的应用程序,目标计算机也需要安装适当的驱动程序。如果目标计算机上没有 MATLAB®,则必须手动安装供应商驱动程序。

安装支持包

要安装所需驱动程序的支持包,请执行下列操作:

  1. 在 MATLAB 主页选项卡的环境部分,点击附加功能 > 获取硬件支持包

  2. 在附加功能资源管理器的左窗格中,滚动到按类型筛选并选中硬件支持包

  3. 按硬件类型筛选下,选中 CAN 设备。附加功能资源管理器显示受支持的 CAN 设备供应商的所有支持包。点击您的设备供应商的支持包。

  4. 点击安装 > 安装。您可能需要登录您的 MathWorks® 帐户,然后继续。

更新或卸载支持包

要卸载支持包,请执行下列操作:

在 MATLAB 主页选项卡的环境部分,点击附加功能 > 管理附加功能

要更新现有支持包,请执行下列操作:

在 MATLAB 主页选项卡的环境部分,点击附加功能 > 检查更新 > 硬件支持包

相关主题