What's wrong with that? It's fast. It's simple. It's intuitive and easy to understand, and thus maintainable by anyone who inherits your code. Looks fine to me.
However, you could do this:
name_list(:) = {'abcdef'}
name_list =
{'abcdef'}
{'abcdef'}
{'abcdef'}
{'abcdef'}
{'abcdef'}
{'abcdef'}
{'abcdef'}
{'abcdef'}
Don't use size as the name of your variable since it's the name of a very important built-in function.