fwrite to fread changes data completely!

9 次查看(过去 30 天)
Hello Friends,
I have a Vector or some length, say, 1 x N with real number entries.
I want to save this vector by using "fwrite" and then read it using "fread". I did the following:
fileID = fopen(Name, 'w');
fwrite(fileID, Vector, 'double', [number_of_rows number_of_columns]);
%Here [number_of rows number_of_cols] = size(Vector);
In workspace, Vector shows of type 'double'
Next, for reading it, I did the following:
fid = fopen(path_to_vector, 'r');
output = fread(fid, [1 length_of_vector], 'double');
However, the "output" shows completely different values than what I saved using "fwrite". I tried to change precision from double to type float, int, etc., but it does not work. How can I get exactly the same vector what I saved?
I will appreciate any advise!


per isakson
per isakson 2016-7-9
编辑:per isakson 2016-7-9
This works for me on R2016a,Win7,64b. (Replacing real*8 by double doesn't change that.)
>> cssm( rand(1,1000) )
ans =
function ok = cssm( vec )
fid = fopen( 'cssm.bin', 'w' );
fwrite( fid, vec, 'real*8' );
fclose( fid );
fid = fopen( 'cssm.bin', 'r' );
out = fread( fid, size(vec), 'real*8' );
fclose( fid );
ok = all(vec==out);
  2 个评论
hello_world 2016-7-9
Thanks you for reply!
I tried it before your answer and it worked for me too. The only difference in my previous code and this response is that while writing "fwrite", you do not use vector size. I do not know how does it make a difference.
per isakson
per isakson 2016-7-9
编辑:per isakson 2016-7-9
vector size &nbspis not a documented input argument of fwrite. See fwrite, Write data to binary file. IMO: fwrite ought to have issued at least a warning.


更多回答(0 个)


Help CenterFile Exchange 中查找有关 Low-Level File I/O 的更多信息

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by