在实时脚本中设置文本格式
R2026b您可以向实时脚本和函数添加格式化文本、表、图像、视频、超链接和方程,以创建可与他人共享的可演示文档。您还可以检查文本的拼写问题并更改文本的字体。
插入文本项目
要插入文本项,请在插入选项卡上,点击 文本以添加空白文本行。要返回到代码,请点击 代码。添加文本行可能会影响代码行编号,具体取决于您保存实时脚本的方式。当您使用纯文本实时代码文件格式 (.m) 保存实时脚本时,每个文本行对应于保存文件中的一个或多个代码行。因此,添加或删除文本行会更改后续任何代码的行号。
下表描述您可以从插入选项卡插入的文本项。
| 选项 | 描述 | 其他详细信息 |
|---|---|---|
文本 | 插入空的文本行。 | 文本行可以包含格式化文本、图像、视频、超链接或方程。您可以在代码行之前、之后或之间插入文本行。 |
目录 | 插入目录。 | 目录包含文档中所有标题的列表。如果文档只包含一个标题,则该标题不包含在目录中。只有目录的标题是可编辑的。 您只能在文本行中插入目录。如果您将目录插入到代码行中,MATLAB® 会将其置于当前代码节的上一行。 将包含目录的实时脚本导出为 Microsoft® Word 时,默认情况下,生成文档的目录不包含页码。要添加页码,请在 Word 中点击目录并选择更新表。 |
代码示例 | 插入格式化的代码示例。 | 代码示例是显示为缩进的等宽文本的示例代码。
|
表 | 插入一个表。 | 您只能在文本行中插入表。如果您向代码行中插入表,则 MATLAB 会将该表置于选定代码行正下方的新文本行中。 要指定表大小,请选择表 插入表后,您可以修改该表的行和列:
|
图像 | 插入图像。 | 您只能在文本行中插入图像。如果您向代码行中插入图像,则 MATLAB 会将该图像置于选定代码行正下方的新文本行中。 要在插入图像后更改图像的替换文本、对齐方式和大小,请右键点击图像并从上下文菜单中选择编辑图像。
|
视频 | 插入一个 YouTube® 视频或视频文件。 | 您只能在文本行中插入视频。如果您向代码行中插入视频,则 MATLAB 会将该视频置于选定代码行正下方的新文本行中。
要调整视频大小,请点击视频的一个边以将其选中。然后,点击并拖动视频的角或边以调整其大小。要还原到原始视频大小,请右键点击选定视频的角或边,然后选择重置视频大小。 |
超链接 | 插入超链接。 | 您只能在文本行中插入超链接。如果您向代码行中插入超链接,则 MATLAB 会将该超链接置于选定代码行正下方的新文本行中。
|
方程 | 插入方程。 | 您只能在文本行中插入方程。如果您向代码行中插入方程,则 MATLAB 会将该方程置于选定代码行正下方的新文本行中。有关详细信息,请参阅将方程插入实时脚本。 |
设置文本格式
要设置现有文本的格式,请使用实时编辑器选项卡的文本部分中包含的各个选项:
| 格式类型 | 选项 |
|---|---|
| 文本样式 | 普通 标题 1 标题 2 标题 3 标题 自定义样式 有关自定义样式的详细信息,请参阅更改字体和颜色。 |
| 文本对齐方式 | 左对齐 居中对齐 右对齐 |
| 列表 | 项目符号列表 编号列表 要创建多级列表,请按 Tab 键缩进带编号或项目符号的项。要减少缩进,请按 Shift+Tab。要将子列表更改为不同列表类型,请使用 项目符号列表和 编号列表按钮。 |
| 标准格式设置 | 加粗 斜体 下划线 等宽 |
要将选定文本或代码转换为全部大写或小写,请选择文本,点击右键,然后选择更改大小写。也可以按 Ctrl+Shift+A。如果文本中同时包含大写和小写文本,则 MATLAB 会将它们全部更改为大写。
检查拼写
自 R2024a 起
您可以检查实时脚本和函数中文本行和注释的拼写问题。可能存在拼写问题的单词以蓝色下划线显示。要解决该问题,请点击该单词并选择建议的更正之一。您也可以选择忽略该问题或将标记的单词添加到您的本地字典中。要使用键盘在问题之间导航,请使用 Alt+F7 和 Alt+Shift+F7。
在 MATLAB 代码文件 (.m)、实时代码文件(.m 和 .mlx)以及 Markdown 文件 (.md) 中支持美国英语的拼写检查。要从本地字典中删除单词,请转至 MATLAB 设置文件夹(运行 prefdir 时返回的文件夹)并编辑文件 dict/en_US_userDictionary.tdi。
默认情况下,拼写检查处于打开状态。如果一个文件包含许多无法识别的单词(例如,当不使用美国英语撰写时),MATLAB 会自动关闭该文件的拼写检查。要手动关闭文件的拼写检查,请转至查看选项卡,然后在审阅部分中,将拼写按钮切换为关闭。要默认关闭所有文件的拼写检查,请在主页选项卡的环境部分中,点击 设置。选择 MATLAB > 编辑器/调试器 > 拼写,并将检查拼写设置为关闭。要更改要进行检查拼写的文本,请在要检查拼写的位置部分中,选中或清除可用的选项。有关详细信息,请参阅Editor/Debugger Spelling Settings。
在 R2026a 之前的版本中: 默认情况下,拼写检查处于关闭状态。要打开拼写检查,请转至视图选项卡,然后在审阅部分中,将拼写按钮切换为打开。此外,拼写设置不可用,并且不支持在 Markdown 文件中进行拼写检查。
更改字体和颜色
您可以在实时脚本和函数中更改文本和代码样式的字体、大小、颜色和格式。
要为当前文档自定义文本或代码样式,请转至实时编辑器选项卡,在文本部分中,点击文本样式下拉列表,然后选择 自定义样式。然后,选择要自定义的样式,并更改选定样式的字体、大小、颜色和格式。“自定义样式”对话框显示每个样式的预览。
自定义样式仅应用于当前文档。要将自定义样式应用于所有新实时脚本,请选择对新实时脚本使用此配置选项。

或者,要以编程方式为所有打开的文档和所有新文档自定义文本或代码样式,请使用 matlab.fonts 设置。所有打开的实时脚本和实时函数都会更新以显示所选字体。当您创建新的实时脚本或函数时,也会应用所选字体。
例如,以下代码会更改实时脚本和函数中标题的颜色和样式:
s = settings; s.matlab.fonts.editor.title.Style.PersonalValue = "bold"; s.matlab.fonts.editor.title.Color.PersonalValue = [0 0 255 1];
缩放
要增大或减小实时脚本和函数中的显示字号,请使用 Ctrl+加号 (+) 和 Ctrl+减号 (-) 键盘快捷方式,或按住 Ctrl 键并使用鼠标滚轮来放大或缩小。在 macOS 系统上,使用 Command 键而不是 Ctrl 键。在将实时脚本导出为 PDF、Microsoft Word、HTML、LaTeX、Markdown 或 Jupyter® Notebook 时,不会应用显示字号的更改。
自动格式化
要在实时脚本和函数中快速进行格式化,您可以将键盘快捷方式和字符序列结合使用。当您输入序列中的最后一个字符后,即会显示格式设置。
下表列出了格式化样式及其可用的键盘快捷方式和自动格式化序列。
| 格式化样式 | 自动格式化序列 | 键盘快捷方式 |
|---|---|---|
| 标题 |
| Ctrl+Alt+L |
| 标题 1 |
| Ctrl+Shift+1 |
| 标题 2 |
| Ctrl+Shift+2 |
| 标题 3 |
| Ctrl+Shift+3 |
| 带标题 1 的分节符 |
| 将光标置于带有 Ctrl+Shift+1,然后 Ctrl+Alt+Enter |
| 分节符 |
| Ctrl+Alt+Enter |
| 项目符号列表 |
| Ctrl+Alt+U |
| 编号列表 |
| Ctrl+Alt+O |
| 斜体 |
| Ctrl+I |
| 加粗 |
| Ctrl+B |
| 加粗和斜体 |
| Ctrl+B,然后 Ctrl+I |
| 等宽 |
| Ctrl+M |
| 下划线 | 无 | Ctrl+U |
| LaTeX 方程 |
| Ctrl+Shift+L |
| 超链接 |
| Ctrl+K |
商标、服务标记和版权符号(™、℠、® 和 ©) |
| 无 |
注意
标题、分节符和列表序列必须在行开头输入。
有时,您可能希望自动格式化序列(例如 ***)按字面显示。要显示序列中的字符,请按 Backspace 键或点击撤消 以退出自动格式化。例如,如果您键入 ## Enter,则会显示标题 1 样式并带有单词 text +text 的标题。要撤消格式化样式并显示 ## text,请按 Backspace 键。您只有在完成序列后立即操作,才能从序列中退出。当您输入其他字符或移动光标之后,便无法再退出。
要恢复 LaTeX 方程和超链接的自动格式化,请随时使用 Backspace 键。
要强制格式化在退出序列后重新出现,请点击重做 按钮。您只能在退出操作后立即重做该操作。一旦您输入其他字符或移动光标,便无法执行重做。在这种情况下,要强制格式化重新出现,请删除序列中的最后一个字符,然后再次键入该字符。
要禁用所有或部分自动格式化序列,您可以调整Editor/Debugger Autoformatting Settings。
