Unrecognized method, property, or field 'queryProxyServer' for class 'matlab.in​ternal.Web​windowMana​gerInterfa​ce'. can not open AddOns

8 次查看(过去 30 天)
I am using Matlab R2021a update 4 on arch linux, and when i try to open AddOns, or click install update there is this error:
Unrecognized method, property, or field 'queryProxyServer' for class 'matlab.internal.WebwindowManagerInterface'.
Error in matlab.internal.cef.webwindowmanager/readProxyServer (line 234)
proxyInfo = wmi.queryProxyServer();
Error in matlab.internal.cef.webwindow (line 304)
windowMgr.readProxyServer(obj.BrowserMode);
Error in matlab.internal.webwindow/createImplementation (line 313)
implObj = matlab.internal.cef.webwindow(varargin{:});
Error in matlab.internal.webwindow (line 161)
obj.impl = obj.createImplementation(varargin{:});
Error in matlab.internal.addons.AddOnsWindow/launch (line 51)
obj.webwindow = matlab.internal.webwindow(char(url), obj.debugPort, obj.normalWindowPosition);
Error in matlab.internal.addons.Explorer/loadUrlForNavigateToMessage (line 125)
obj.addOnsWindowInstance.launch(url, obj.windowStateUtil.getExplorerWindowMaximizedSetting);
Error in matlab.internal.addons.Explorer/show (line 56)
obj.loadUrlForNavigateToMessage(url);
Error in matlab.internal.addons.launchers.showExplorer (line 136)
matlab.internal.addons.Explorer.getInstance.show(navigationData);
also when i launch matlab it works properly but there is this messege:
Failed to load module "canberra-gtk-module"
  3 个评论
Ashutosh Singh Baghel
Could you please run the following commands and send the response -
1. Execute the following commands and check if CEF browser launches successfully.
a = matlab.internal.webwindow('http://mathworks.com');
a.show;
2. Try to launch Add-On Manager and see if it works: Add-Ons -> Manage Add-Ons

请先登录,再进行评论。

采纳的回答

Ashutosh Singh Baghel
Hi Yash,
The "queryProxyServer" method that is mentioned in the error message was introduced in R2021a 'Update 5'. As you are using 'Update 4', then it looks like you tried to copy some Update 5 files into the installation path, which won't work.
Likely, you need to either reinstall 'Update 4' to get a good installation or upgrade to 'Update 5'.
Also, I beleive the error you are getting is an reported issue. Please refer to the following link for a workaround.
  1. Why do I get the startup error : Failed to load module "canberra-gtk-module" or "pk-gtk-module" in R2019a on Redhat Linux?
  2. QRG for "Failed to load module "canberra-gtk-module" error"
  1 个评论
Yash Pajvani
Yash Pajvani 2021-9-27
Hii Ashutosh this is true, actully i tried to upgrade from update4 to update5 but update was not successfull due to some permission issue in linux, finally i uninstall and install again which solve the problem.

请先登录,再进行评论。

更多回答(0 个)

产品


版本

R2021a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by