sudo ./install doesn't start on Linux

202 次查看(过去 30 天)
Domenico Notarangelo
Domenico Notarangelo2021-10-9
编辑: Robert Kirkby ,2022-1-19,2:53
I've downloaded zip file of MATLAB R2021b for linux and when i tried to use the command sudo ./install nothing happen, i've tried with sudo sh ./install but nothing. Terminal give me no messages and i don't know what to do but i need matlab on my pc. It seems like the file named install doesn't work, how can i solve?
  3 个评论

请先登录,再进行评论。

回答(2 个)

Tanmay Das
Tanmay Das 2021-10-12
Hi,
To my understanding, you are not able to launch MATLAB R2021b in your linux terminal. The most likely reason is that you do not have permissions to one or more of the files in the installation folder. A similar question has been answered previously the link to which has been attached below. It might help you resolve your issue.
  1 个评论
Niladri Sekhar Mandal
I could not install 2021b, but could install 2020b without any setting changes. It seems there is a bug in the installer.

请先登录,再进行评论。


David Wilby
David Wilby 2021-11-17
I'm also having this issue on ubuntu linux 18.04 with R2021b. This seems like quite a critical failure for Linux users. Are there any plans to fix this bug in the installer?
  4 个评论
Robert Kirkby
Robert Kirkby 2022-1-19,2:47
Same problem with R2021b on Kubuntu 20.10:
./install runs fine but obviously can't install to /usr/local/ as don't have access privelidges
sudo ./install the gui never appears (nothing happens, the command line claims to be running the installer when I quit it)
(can install R2021a just fine)

请先登录,再进行评论。

产品


版本

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by