Matlab recognizes arduino but not other code.

55 次查看(过去 30 天)
I'm pretty new to using matlab/arduino together so this is probably a simple problem. I installed the arduino add-on from mathworks and have gotten matlab to recognize my arduino uno using:
a = arduino('COM3');
but none of the arduino commands work that I have tried:
a.pinMode(13,'output');
pinMode(a,13,'output');
a.digitalWrite(13,1);
digitalWrite(a,13,1);
a.analogRead(0)
analogRead(a,0)
and all of them bring up the same error message:
' _No appropriate method, property, or field pinMode for class arduino._'
I'm not sure why they don't work.

采纳的回答

Andrew Miller
Andrew Miller 2014-11-1
Thanks a lot for your help. I was still having the same problem after installing it as an administrator so I looked at the MATLAB Arduino help and it appears that they have changed the coding syntax. For example: to specify output pins then instead of a.pinMode(22,'output') then it is a.configureDigitalPin(22,'output') or turning on the power instead of a.digitalWrite(22,1) then it is a.writeDigitalPin(22,1). I'm not sure on what version of MTALB the change took place but this fixed the problem.
  2 个评论
William
William 2015-6-25
This answer solved my problem as well. Thank you.
Walter Roberson
Walter Roberson 2016-11-11
jahanzeb hasmni comments to Andrew Miller:
very authentic and right on the target.

请先登录,再进行评论。

更多回答(2 个)

Geoff Hayes
Geoff Hayes 2014-10-18
Andrew - a similar problem was discussed matlab and arduino where the same error No appropriate method, property, or field pinMode for class arduino. The solution was to install the Arduino support package after having started MATLAB in administrator mode.
  4 个评论
Geoff Hayes
Geoff Hayes 2014-10-22
Andrew's comment moved here
Ok. So I read through the post that Hayes suggested and it talks about about making other users have the same preferences as the administrator. The problem is that I only have one account on a windows 8 laptop and it is set up as the administrator. I ran matlab R2014a (student version) as an administrator, right clicked on the package. It didn't have an option for install as administrator. So I just double clicked on it and it then opened up another matlab window and insalled the package. Since it opened up another matlab window then I'm not sure if it is installing as an administrator. Do I also need to install the package as an administrator and if so how would I do that? Also it looks like the packages are located in the following folder
C:/MATLAB/SupportPackages/R2014a if that helps.
Geoff Hayes
Geoff Hayes 2014-10-22
Obviously you can ignore the part about the other user accounts since there is just you using that computer.
Rather than running the installation package through your browser (which does seem to open a new instance of MATLAB), just save it to file (when I tried it now, the saved file is arduinoio.mlpkginstall). Then launch your instance of MATLAB as an administrator. Change directory to the folder where the install package has been downloaded (or move that file to your default MATLAB directory), then double-click on the file. It will launch the Support Package Installer without launching another instance of MATLAB.

请先登录,再进行评论。


yati j
yati j 2016-10-6
Hi! i had downloaded the package IO Library but after i wanna add to the matlab, matlab see nothing in my folder..how can i add the io library..thank You
  7 个评论
Walter Roberson
Walter Roberson 2016-10-6
Download the .zip into a directory, and unzip it, and in MATLAB cd into the directory and run install_arduino

请先登录,再进行评论。

类别

Help CenterFile Exchange 中查找有关 MATLAB Support Package for Arduino Hardware 的更多信息

标签

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by