PX4 PIL error: configured for external mode which is not supported

4 次查看(过去 30 天)
I've tried to run PIL(Processor In the Loop) for my own simulink file.
I set my settings properly, and the example code
run and shows result well.
However, When I run my own simulink file for PIL, some error occured and it says:
The SIL or PIL component "{my File name}" is configured for external mode which is not supported. To avoid this error change the data exchange interface setting in the Interface Configuration Parameters.
This is my setting in hardware implementation - Target hardware resources - External mode
I tried to my Commuication interface from XCP on Serial to Serial or uncheck "Use he same host serial port for external mode" and set proper usb port which is connected Pixhawk board but both didn't work.
Can you help me why this error occurred?
Thank you.


Arun Mathamkode
Arun Mathamkode 2021-12-6
I think this might be due to a wrong active configuration set in the model. Navigate to the 'Model Explorer' and see what is the active configuration for your model. I guess the configuration with external mode might be stil active. Please make it inactive and activate the normal (without external mode) configuration as the active one. Have a look at this documentation to understand how to manage configuration sets.

更多回答(0 个)




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by