Why do I get XCP internal error: timeout expired?

41 次查看(过去 30 天)
I have tried to follow this example, but using a Cube Orange instead, which I set up using this guide except on Ubuntu instead of Windows.
But somewhere I messed something up. When I try to run "monitor & tune" on the board, I get the following error:
0 of 1 models built (1 models already up to date)
Build duration: 0h 1m 15.535s
action: EXT_INIT
Creating Target Handler (XCP on Serial)...
Build directory: /home/soren/heavy_duty/matlab/untitled_ert_rtw
Serial Port Name: /dev/ttyUSB0
Baud Rate: 57600
Connecting to the target...
External Mode Open Protocol Connect command failed
Caused by:
Could not connect to target application: XCP internal error: timeout expired, in response to XCP CONNECT command
I have determined it seems like the problem is with the communication between Cube Orange using Telem 1 on the Pixhawk (where I have the FTDI serial converter in). I have tried using different baud rates but can't determine what exactly is the problem with the connection.
  2 个评论
Søren 2023-8-11
Unfortunately I never managed to solve it. I had other task to do, didn't spend a lot more time on the issue


回答(1 个)

Arun Mathamkode
Arun Mathamkode 2023-1-2
编辑:Arun Mathamkode 2023-1-3
TELEM1 serial port are fundamentally designed for MAVLink communication and by default MAVLink is enabled in this port. You can consider trying to connect using GPS2 port (/dev/ttyS5). Makesure that parameters GPS_1_CONFIG or GPS_2_CONFIG is not set to enable GPS2 as a GPS port.
  5 个评论
Salvatore Matteo Mennea
@Arun Mathamkode I've tried all the solution you have written in the post but I have the same error.
I'm using win 10 and Pixhawk 6x with matlab 2023b





Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by