Questions about mapping toolbox

9 次查看(过去 30 天)
I tried to run following codes. But it gave a 0x1 empty 'layers' and following warning. Does anyone know what is happening please? I am trying to get the elevation information from a map server. Thank you for your help.
layers = wmsfind('*elev', 'SearchField', 'serverurl');
layers = wmsupdate(layers);
Warning: An error occurred while attempting to update layers from the server, ''. These layers are being removed from
the layer array. The number of layers from this server that are being removed from the layer array is 11. The error message returned by the server is:
'Expected the capabilities document from the server, '', to contain valid XML.'.
  1 个评论
Walter Roberson
Walter Roberson 2017-1-9
I confirm the problem. Unfortunately, I do not have any ideas why it is happening.



Ed Marquez
Ed Marquez 2017-1-12
编辑:Ed Marquez 2017-1-12
I was able to run the code you shared with no warnings or errors. 'layers' was generated and has the 11 layers that are expected. I attached the variable 'layers' as a MAT file to this answer so you can check.
It seems like the issue could be computer or connection specific...
Also, I ran the code in all MATLAB versions between R2014a and R2016b and 'layers' was always generated, so the issue may not be related to a specific MATLAB version.
  4 个评论
Walter Roberson
Walter Roberson 2017-5-8
I just tested now with the code posted in the original Question, and the code worked for me in R2017a but not in R2016b.


更多回答(2 个)

Alessandro 2017-5-9
编辑:Alessandro 2017-5-9
Hi. Have you found a solution for the issue? I'm experiencing the same problem.
  1 个评论
Walter Roberson
Walter Roberson 2017-5-9
Alessandro, which MATLAB version are you using?


Olga Galluppi
Olga Galluppi 2017-7-7
I have the same problem, can someone help ?


Find more on Argument Definitions in Help Center and File Exchange


Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by