Error while running a model on Raspberry pi

11 次查看(过去 30 天)
I am using a raspberry pi camera for taking a continuous video for my image processing network. At first, when I tried to run my model, it worked fine. But later on when I tried to run the same model, I got error messah=ge like:
The model that you are trying to run in External mode does not match the application running on your target. Checksum test (TARGET_CONNECT) failed. The host model's structural checksum is [3952797520, 3164253609, 4022928347, 1013116400] and the target application's structural checksum is [812222564, 2062717974, 3160967008, 2531862615]. Rebuild the model, run it on your target, and start External mode simulation again. Component:Simulink | Category:Model error Unable to connect to the 'Raspberry Pi' target for 'TRIAL_2'.
Please help me out this problem ASAP. Thanks in advance.


Mohith Prabhu
Mohith Prabhu 2018-2-23
编辑:Mohith Prabhu 2018-2-23
Try the following
1) If you have made changes to your model, save the model before deploying.
2) Clean up all the files related to your model on the Raspberry Pi. Relaunch the model in External Mode.
Hope this helps.
  2 个评论
Mohith Prabhu
Mohith Prabhu 2018-12-18
From your MATLAB command window, execute the following
>> mypi = raspberrypi();
>> openShell(mypi)
In the putty window which opens up, execute the 'ls' command to find out all the folders under /home/pi.
If for eaxmple, your model is named 'myModel', the there would be a folder named 'myModel' inside which all the files related to that model would exist. Delete this model by executing 'rm -rf mymodel'.
This should clean up all the files related to your model.


更多回答(1 个)

venkatesh mane
venkatesh mane 2019-5-3


Help CenterFile Exchange 中查找有关 Image Processing and Computer Vision 的更多信息

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by