High CPU usage when matlab is idle on Linux

9 次查看(过去 30 天)
Livio
Livio2012-7-18
Hi all, I installed Matlab 7.14.0.739 (R2012a) on a core i5 machine with 4 GiB of RAM. The OS is Ubuntu 11.04 64 bit. Matlab works fine, (apart from some Unix version related issues), but when idle it takes more than 100% CPU. The top command reports:
PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
17162 newcesir 20 0 1137m 382m 70m S 107 4.8 2:35.14 MATLAB
9 root 20 0 0 0 0 S 21 0.0 898:12.00 ksoftirqd/1
3 root 20 0 0 0 0 S 19 0.0 923:00.86 ksoftirqd/0
13 root 20 0 0 0 0 S 10 0.0 779:41.32 ksoftirqd/2
16 root 20 0 0 0 0 S 0 0.0 640:55.65 ksoftirqd/3
The 4 ksoftirqd processes have something to do with interrupt handling for the 4 processors, and are assciated with the matlab running. The machine is multi user, and having one cpu occupied for every matlab instance started is not good at all. Does anyone know why this is happening? Thank you
  4 个评论
Walter Roberson
Walter Roberson 2012-7-20
Different startup scripts?
Also, I would suggest deleting the MATLAB preferences file and re-creating it.

请先登录,再进行评论。

采纳的回答

Adam Filion
Adam Filion 2012-7-20
编辑:Adam Filion 2012-7-20
Have you rebooted your Linux machine since July 1? If not then that may be the problem. There was a bug with Linux that caused all kinds of problems with the leap second on July 1:
This bug has caused some strange behavior for various programs, MATLAB included. Rebooting the machine fixes the problem. If that doesn't resolve it then I recommend contacting tech support:
[EDIT fixed links]
  6 个评论

请先登录,再进行评论。

更多回答(0 个)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by