Arduino simulink connection error

59 次查看(过去 30 天)
Muhammad Rizwan
Muhammad Rizwan 2020-6-29
评论: Santiago Avila ,2023-9-16,18:28
I am trying to run Arduino example on my Arduino uno board from simulink.
Every time it shows the same error though I changed ports number and also reinstalled packages too.
Could not connect to specified Arduino board.
Verify that the board is connected to your host, and that the host COM port number set in the model matches the COM port number in Windows.
To change the host COM port number in the model, click 'Simulation ', click 'Model Configuration Parameters'... In the dialog that opens, select the 'Hardware Implementation' pane, click 'Target hardware resources > Host-board connection' and set the COM port number.
To find out the COM port number in Windows, open Device Manager and open your board in the COM ports group.
In matlab window if I enter arduino() it shows the connection details though.
  3 个评论
Natasha Smith
Natasha Smith 2022-12-27
I'm having the same issue. Have tried everything in this thread to no avail.


回答(2 个)

Mohith Prabhu
Mohith Prabhu 2020-7-1
Hello Muhammad Rizwan,
Here are a few pointers to try and resolve the issue that you are facing
1) Make sure the model is configured for the correct hardware that you intend to use. You can change the Hardware board in the Hardware Implementation section of the Simulink Configuration settings.
2) Once the hardware is set correctly, if you continue to see the issue, you can try specifying the COM port number of your hardware bord manually in the Configuration Settings. In the Simulink Configuration settings, navigate to Hardware Implementation > Hardware board settings > Target Hardware resources > Host-board connection. Change the "Set host COM port" option to "Manually". In the COM port number dialog box, enter the COM port number corresponding to your hardware. You can find the COM port number for your board from the Windows hardware manager.
3) In the case of using MATLAB support package for Arduino hardware along with the Simulink support package for Arduino hardware, ensure that you do not have any active connections between the MATLAB and the hardware, To ensure this, you can proceed to Simulink model deployment after clearing any existing "arduino" connections from MATLAB to your hardware.
Hope this helps.
Kindly let us know if these pointers help you resolve the issue.
Thanks and Regards,
Mohith Prabhu
  2 个评论
Mohith Prabhu
Mohith Prabhu 2020-7-1
In that case, may I request you to contact MathWorks technical support for further assistance


경민 박
경민 박 2022-7-22
I had same problem, and this is how I solved it.
In my case, I created new empty folder, and then in MATLAB I moved my Current Folder to that new empty folder.
Then it worked.


Help CenterFile Exchange 中查找有关 Simulink Support Package for Arduino Hardware 的更多信息




Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by