Product Requirements & Platform Availability for Financial Instruments Toolbox

Supported Platforms

Windows, Mac, Linux

Product Requirements

  • Requires MATLAB
  • Requires Financial Toolbox
  • Requires Optimization Toolbox
  • Requires Statistics and Machine Learning Toolbox
  • The fitSmoothingSpline function requires Curve Fitting Toolbox
  • Econometrics Toolbox recommended
  • Datafeed Toolbox recommended
  • Curve Fitting Toolbox recommended
  • Global Optimization Toolbox recommended
  • Database Toolbox recommended

Eligible for Use with MATLAB Compiler and Simulink Compiler

Yes

Eligible for Use with Parallel Computing Toolbox and MATLAB Parallel Server

Yes

Introduced in R2012b

View requirements for another product: