主要内容

线性系统分析器

R2026b

分析线性时不变 (LTI) 系统的时域响应和频域响应

描述

线性系统分析器可用于分析 LTI 系统的时域响应和频域响应。

使用此 App,您可以:

  • 查看和比较 SISO 和 MIMO 系统的响应图,或同时查看和比较几个线性模型的响应图。

  • 生成时间响应图,如对任意输入的阶跃响应、冲激响应和时间响应。

  • 生成频率响应图,例如波特图、奈奎斯特图、尼柯尔斯图、奇异值图和零极点图等。

  • 检查关键响应特征,如上升时间、最大超调量和稳定裕度。

线性系统分析器可以生成以下响应图:

  • 阶跃响应

  • 冲激响应

  • 对指定输入信号的仿真时间响应

  • 指定初始条件下的仿真时间响应(仅限状态空间模型)

  • 波特图(幅值和相位,或仅幅值)

  • 奈奎斯特图

  • 尼柯尔斯图

  • 奇异值图

  • 零极点图和 I/O 极点/零点图

Linear System Analyzer app

打开 线性系统分析器 App

  • MATLAB® 工具条:在 App 选项卡上的控制系统设计和分析下,点击 App 图标。

  • MATLAB 命令提示符:输入 linearSystemAnalyzer。

示例

全部展开

要将模型导入线性系统分析器中,请选择文件 > 导入。系统将打开“导入系统数据”对话框。

Import System Data dialog box with the Import from drop-down list set to Workspace. Below, the Systems in Workspace table lists three models. The leftmost Import column contains checkboxes for selecting models.

在导入自下,选择是否从以下来源导入模型:

  • MATLAB 工作区(选择工作区)

  • MAT 文件(选择 MAT 文件)

在表的导入列中,选择一个或多个要导入的模型。

点击导入。

要从线性系统分析器导出模型,请选择文件 > 导出。系统将打开“线性系统分析器导出”对话框。

Linear System Analyzer Export dialog box with a Select Models to Export table with two models available for export. The leftmost Export column contains checkboxes for selecting models.

在表的导出列中,选择一个或多个要导出的模型。

要将模型导出到 MATLAB 工作区,请点击导出到工作区。

要将模型导出到 MAT 文件,请点击导出到磁盘。

在“选择要写入的文件”对话框中,指定保存的 MAT 文件的名称和位置,然后点击保存。

要从线性系统分析器删除模型,请选择编辑 > 删除系统。系统将打开“线性系统分析器删除”对话框。

Linear System Analyzer Delete dialog box with a Select Models to Delete table with two models available for deletion. The leftmost Select column contains checkboxes for selecting models.

在选择列中,选择一个或多个要删除的模型。

点击删除。

要在线性系统分析器中以交互方式指定要绘制的响应类型,请选择编辑 > 绘图配置。系统将打开“绘图配置”对话框。

Plot Configurations dialog box showing selectable response plot layouts represented by icons, including single‑plot, two‑plot stacked, three‑plot stacked, and multi‑panel grid arrangements with up to six plots. Below, there are drop-down lists to select the response type for each plot in the configuration.

在选择响应图配置部分中,选择要显示的绘图数量。

在响应类型部分中,使用下拉列表为每个绘图选择响应类型。

要更新绘图配置并关闭对话框,请点击确定。

要更新绘图配置而不关闭对话框,请点击应用。

要切换现有绘图的响应类型,请右键点击该绘图,然后在绘图类型下选择响应类型。

Step response plot with the right-click menu open and the cursor over the Plot Types > Bode menu item.

要在线性系统分析器中以交互方式指定响应的线型,请选择编辑 > 响应样式。系统将打开“响应样式”对话框。

Response Styles dialog box with configured to distinguish systems by color and no distinction for inputs and outputs. Below, lists for the color, marker order, and line-style order show the order in which these values are applied. There are up and down arrows for adjusting the order in each list.

在区分显示部分中,您可以使用对应的下拉列表选择如何区分系统、输入和输出。

这些下拉列表中的选项是互斥的,也就是说,您必须为系统、输入和输出使用不同类型的排序方式。

线性系统分析器分别根据色序、标记序列和线型序列中指定的顺序,为响应分配颜色、标记样式和线型。

您可以通过点击列表中的某一项并使用对应的箭头调整其位置来修改这些顺序。

要更新响应样式并关闭对话框,请点击确定。

要更新响应样式而不关闭对话框,请点击应用。

要在响应图中显示响应特征,请右键点击绘图区域,然后在特征下选择要显示的特征。您可以在同一绘图上显示多个特征。

Step response plot with the right-click menu open and the cursor over the Characteristics > Peak Response menu item.

可用的特征取决于响应图的类型。

响应图可用特征
阶跃图
  • 峰值响应

  • 上升时间

  • 稳定时间

  • 瞬态时间

  • 稳态

冲激图
  • 峰值响应

  • 瞬态时间

初始条件图
线性仿真图

峰值响应

奇异值图
波特图
  • 峰值响应

  • 所有稳定裕度

  • 最小稳定裕度

奈奎斯特图
尼柯尔斯图
零极点图无
每个输入/输出对组的零极点图

绘图使用标记在响应上显示每个特征。要查看有关特征的信息,请点击相应标记。

Step response plot with a data tip located at the peak response value. The data tip is expanded to show the response name, peak deviation value, peak overshoot percentage and time.

相关示例

编程用途

linearSystemAnalyzer 打开线性系统分析器,但没有要分析的 LTI 系统。有关如何导入系统的信息,请参阅导入模型。

linearSystemAnalyzer(sys1,sys2,...,sysN) 打开线性系统分析器并显示一个或多个动态系统模型(sys1、sys2、...、sysn)的阶跃响应。此类模型包括:

  • 数值 LTI 模型,如 tf、zpk 或 ss 模型。

  • 辨识模型,如 idtf、idss 或 idproc(需要 System Identification Toolbox™ 软件)。

  • 广义 LTI 模型,如 genss 或 uss 模型。对于没有不确定性的广义 LTI 模型,线性系统分析器绘制模型标称值的响应。对于具有不确定性的广义模型,该 App 绘制不确定系统的 20 个随机样本的响应。(不确定模型需要 Robust Control Toolbox™ 软件。)

linearSystemAnalyzer(sys1,LineSpec1,...,sysN,LineSpecN) 指定每个响应图的线型、标记和颜色。

有关线型设定的详细信息,请参阅 lsimplot 函数的 LineSpec 输入参量。

linearSystemAnalyzer(plottype,___) 打开线性系统分析器并显示由 plottype 指定的响应类型。此语法可与上述任一输入参量组合结合使用。plottype 参量可以是以下任一项:

  • "step" - 阶跃响应

  • "impulse" - 冲激响应

  • "lsim" - 线性仿真图。如果您未使用 extras 语法指定输入向量和时间向量,则系统会打开线性仿真工具对话框,提示您指定输入向量和时间向量。

  • "initial" - 初始条件图(仅限状态空间模型)。您必须使用 extras 语法指定初始条件。

  • "bode" - 波特图

  • "bodemag" - 波特幅值图

  • "nyquist" - 奈奎斯特图

  • "nichols" - 尼柯尔斯图

  • "sigma" - 奇异值图

  • "pzmap" - 零极点图

  • "iopzmap" - LTI 系统的每个输入/输出对组的零极点图

要在打开线性系统分析器的同时附带打开多种响应图,请指定最多包含六种绘图类型的字符串数组。例如,以下命令打开该 App,其中包含系统 sys 的阶跃响应图和奈奎斯特图。

linearSystemAnalyzer(["step","nyquist"],sys)

linearSystemAnalyzer(plottype,sys1,sys2,...,sysn,extras) 指定特定于响应图类型的附加输入参量。extras 可以是除 plotoptions 参量和名称-值参量外,对应于绘图类型的函数可用的一个或多个输入参量。

要确定 extras 的适当参量,请参阅对应于每种绘图类型的函数(如 stepplot、bodeplot 或 initialplot)的参考页。

例如,假设 plottype 是 "step"。则 extras 使您能够使用可以与 stepplot 命令结合使用的附加参量,例如所需的最终时间 Tfinal。因此,以下命令打开该 App 并显示 sys 的阶跃响应图以及 Tfinal 的最终时间。

linearSystemAnalyzer("step",sys,Tfinal)

如果 plottype 是 "initial",则您必须使用 extras 提供初始条件 IC。例如,以下命令将初始条件设置为状态值向量 x0。

linearSystemAnalyzer("initial",sys,x0)

如果 plottype 是 "lsim",则您可以使用 extras 指定输入向量 u 和时间向量 t。

h = linearSystemAnalyzer(___) 返回线性系统分析器图窗的句柄。此语法可与上述任一输入参量组合结合使用。使用句柄修改之前打开的线性系统分析器实例,如下面两个语法中所述。

linearSystemAnalyzer("clear",h) 清除与句柄 h 对应的线性系统分析器会话中的绘图和数据。要一次清除多个 App 实例,请将 h 设置为句柄向量。

linearSystemAnalyzer("current",sys1,sys2,...,sysn,h) 将系统 sys1、sys2、...、sysn 的响应添加到与句柄 h 对应的线性系统分析器会话。要一次更新多个 App 实例,请将 h 设置为句柄向量。如果新系统的 I/O 维度与当前显示的系统不同,App 将清除现有响应,仅显示新响应。

版本历史记录

在 R2015a 中推出