MATLAB Answers

Cannot Set up Simulink Real Time

22 views (last 30 days)
Hasan Abed Al Kader Hammoud
Commented: Timothy on 24 Jan 2020 at 22:11
Hello All!
I've been trying to run simulink real time for more than 12 hours without any successful attempt. Below are the attempts I've done in details:
Note I'm Using Matlab 2019a
  1. Attempt 1 - Simulink Ethernet Connection: I've connected my laptop (Dell Latitude 7490) which is the host to the target (Dell OptiPlex 7060 Micro) using ethernet cable. Then in "Control Panel\Network and Internet\Network Connections" I modified the ipv4 settings to the following : IP Address : 192.168.10.200 , Subnet Mask: 255.255.255.0 and Default Gateway to 192.168.10.1 . Afterwards I ran slrtexplr in Matlab command window. The settings I chose for my TargetPC1 are IP Address : 192.168.10.201 , Subnet Mask: 255.255.255.0 , Port:22222 , Default Gateway to 192.168.10.1. Bus Type:PCI , Ticked both USB and Graphics Mode , and boot mode is "Network". Afterwards (having the target PC on) I pressed on "Create Boot Disk" , restarted my target and got a prompt that detected the IP with MAC address correctly. Pinging to this using CMD and trying to use (slrttest) both returned failure in pinging.
  2. Attempt 2 - Simulink Removable Disk: With the same setup as the Ethernet Connection I only changed Boot Configuration to removable disk and created boot disk. Afterwards (doing proper bios changes) I connected the USB to the target PC and Simulink Interface page opened (black screen with simulink logo). I tried doing ethernet connection with the PC while its running from the USB but the pinging failed and I have no idea how I can send the simulations to the target machine.
  3. Attempt 3 - DOS Loader: For this attempt I used Rufus to download FreeDOS on the USB. Afterwards I went to the project and built it (it returned an error that it cannot find the target) nevertheless I got the .mldatx file. Then I went back to the slrtexplr page I changed the boot mode to "DOS Loader" and got the files on the USB. To the files I added the .mlxdatx file , booted the target from the USB and ran autoexec.bat. This gave the exact same black page with Simulink Logo without anything running.
Note I'm Using Matlab 2019a and I'm using the default Simulink Real Time project template however I replaced the stuff inside with a Pulse Generator and a Real Time Scope.
Thank You !

  12 Comments

Show 9 older comments
Hasan Abed Al Kader Hammoud
I put Simulink Real-Time 2017b on a removable disk. Booted the target with it and nothing appeared just a blank black screen.
Hasan Abed Al Kader Hammoud
Thank you a lot Jonas. I will call the technical support today.
Timothy
Timothy on 24 Jan 2020 at 22:11
Hasan Abed Al Kader Hammoud, did you receive an answer from technical support? Were they able to help? I am trying to setup a SLRT target PC in R2017b and getting only a black screen as well.

Sign in to comment.

Answers (0)

Sign in to answer this question.

Products


Release

R2019a

Translated by